开启Vim的Python支持

本网站用的阿里云ECS,推荐大家用。自己搞个学习研究也不错
如果你要在VIM中增加诸如YouCompleteMe这一类的插件的话,那么你需要VIM有Python的支持,这个是在一开始编译的选项里指定的。具体操作如下:

1、查看是否支持python

vim –version | grep python

说明没有加入Python支持,这个时候如果使用YouCompleteMe这个插件,就会出现这样的警告

2、解决方法:重新编译安装Vim,开启Vim的Python支持,即可。

./configure  –enable-pythoninterp=yes –with-python-config-dir=/usr/lib64/python2.6/config

提示:可能遇到下面的问题

解决办法:

yum install python-devel

3、再次查看,Vim已经加入Python支持

————————————–分割线 ————————————–

把VIM打造成一个简单实用的IDE http://www.linuxidc.com/Linux/2011-06/37032.htm

Vim学习指南 http://www.linuxidc.com/Linux/2013-08/89096.htm

快速学会 Vi编辑器 http://www.linuxidc.com/Linux/2013-08/88586.htm

强大的Vim 编辑器 http://www.linuxidc.com/Linux/2013-07/87544.htm

CentOS 6.2上搭建Vim开发环境 http://www.linuxidc.com/Linux/2013-07/87363.htm

CentOS 5.4 安装高亮Vim编辑工具 http://www.linuxidc.com/Linux/2013-06/86508.htm

Vim技巧分享:C语言设置 http://www.linuxidc.com/Linux/2012-12/77124.htm

Ubuntu中设置Vim的行号 http://www.linuxidc.com/Linux/2012-12/75485.htm

Vim编辑器使用基础教程 http://www.linuxidc.com/Linux/2013-05/84031.htm

————————————–分割线 ————————————–

未经允许不得转载:演道网 » 开启Vim的Python支持

赞 (0)
分享到:更多 ()

评论 0

评论前必须登录!

登陆 注册