Eclipse无法编译Android故障排除

本网站用的阿里云ECS,推荐大家用。自己搞个学习研究也不错

<

div id=”content” contentScore=”1309″>更新了一下Android sdk,中途拔了几次网线?总之更新完毕后,总是提示有若干可用更新,但更新完成后还是提示。

没把这事当回事。

今天出问题了,每个项目都有错误,看看错误提示,都是这个:

com.android.ide.eclipse.adt.internal.project.AndroidManifestHelper

以为是环境变量有问题,新建android的demo工程,各版本的demo均定位准确,排除。

打开eclipse的错误日志,发现一条重要 信息:!MESSAGE Unable to load the repository jar:file:/E:/work/ADT-0.9.6.zip/
该死,已经更新到adt 10,怎么还在找这个。

看起来,故障原因是更新某个问题引起了adt的版本混乱。

eclipse中help, install new softwares,avaliable software sites中,找到其它的adt安装信息,删除掉

重启eclipse一般会恢复正常,有时候也会报错,选择project,clean可以清除,或者新建一个workspace

如果报这种错误:Error generating final archive: Debug certificate expired on xxxxxx(日期)
eclipse中Window,Preferences,Android,Build中Default debug keystore显示了地址xxx/.android/debug.keystore”,删除此輯div>

未经允许不得转载:演道网 » Eclipse无法编译Android故障排除

赞 (0)
分享到:更多 ()

评论 0

评论前必须登录!

登陆 注册